Configurer des protocoles de routage sur un Cisco ASA

Comme promis lors du tutoriel Configuration de base d’un Cisco ASA voici un petit tutoriel qui va vous apprendre à configurer de la connectivité IP sur un Cisco ASA. Au programme donc, routage statique, protocoles RIP, EIGRP et OSPF. Rentrons donc directement dans le vif du sujet ;-).

Petit rappel avant de commencer. Sur les équipements Cisco, les protocoles de routage possèdent tous une Distance Administrative (DA) qui permet de privilégier certaines informations par rapport à d’autres. Je m’explique, chaque protocole de routage possède sa propre DA et cette dernière est prise en compte dans le choix du chemin à emprunter. En définitive, si un équipement possède deux routes identiques annoncées par deux protocoles différents, l’équipement choisira la route proposée par le protocole de routage possédant la DA la plus faible. Voici donc un tableau récapitulatif des protocoles les plus utilisés ainsi que leur DA associée (il s’agit des valeurs Cisco par défaut, elles sont personnalisables afin de pouvoir privilégier un protocole à un autre) :

DA-Cisco

Configurer une route statique ainsi qu’une route backup

Dans cet exemple nous avons les paramètres suivants :

  • Un réseau « inside » en 192.168.0.0/24 (interface fa 0/1)
  • Un réseau « outside » en 172.16.0.0/24 (interface fa 0/0)
  • Le réseau « outside » est relié à Internet par le biais des adresses IP 209.78.96.23 et 188.73.251.2

Voici la configuration à appliquer :

! On va superviser la première adresse IP afin d'assurer la connectivité
! si cette adresse venait à être non-joignable
sla monitor
type echo protocol ipIcmpEcho 209.78.96.23 interface outside
!
sla monitor schedule 1 life forever now
track 1 rtr 1 reachability
!
route inside 0.0.0.0 0.0.0.0 172.16.0.254
! On configure la route par défaut
route outside 0.0.0.0 0.0.0.0 209.78.96.23 track 1
! On configure la route backup
route outside 0.0.0.0 0.0.0.0 188.73.251.2 100

Configurer le protocole RIP

Dans cet exemple nous avons les paramètres suivants :

  • Un réseau « inside » en 192.168.0.0/24 (interface fa 0/1)
  • Un réseau « outside » en 172.16.0.0/24 (interface fa 0/0)
  • Le réseau « outside » est relié aux autres réseaux

Voici la configuration à appliquer :

router rip
 version 2
 no auto-summary
 default-information originate
 passive-interface FastEthernet 0/1
 network 192.168.0.0
 network 172.16.0.0
!
! On configure de l'authentification RIP pour sécuriser les échanges
interface FastEthernet 0/0
 rip authentication mode md5
 rip authentication key MY-KEY key_id 1

Configurer le protocole EIGRP

Dans cet exemple nous avons les paramètres suivants :

  • Un réseau « inside » en 192.168.0.0/24 (interface fa 0/1)
  • Un réseau « outside » en 172.16.0.0/24 (interface fa 0/0)
  • Le réseau « outside » est relié aux autres réseaux

Voici la configuration à appliquer :

router eigrp 1
 network 192.168.0.0
 network 172.16.0.0
 no auto-summary
 passive-interface FastEthernet 0/1
!
! On configure de l'authentification EIGRP pour sécuriser les échanges
interface FastEthernet 0/0
 authentication mode eigrp 1 md5
 authentication key eigrp 1 MY-KEY key-id 1

Configurer le protocole OSPF

Dans cet exemple nous avons les paramètres suivants :

  • Un réseau « inside » en 192.168.0.0/24 (interface fa 0/1)
  • Un réseau « outside » en 172.16.0.0/24 (interface fa 0/0)
  • Le réseau « outside » est relié aux autres réseaux

Voici la configuration à appliquer :

router ospf 1
 log-adj-changes
 passive-interface FastEthernet 0/1
 network 192.168.0.0 255.255.255.0 area 0
 network 172.16.0.0 255.255.255.0 area 1
!
! On configure de l'authentification OSPF pour sécuriser les échanges
interface FastEthernet 0/0
 ospf authentication message-digset
 ospf message-digset-key 1 md5 MY-KEY
No comments
ClémentConfigurer des protocoles de routage sur un Cisco ASA

Related Posts

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *